WordPress Core Remote Code Execution (RCE) Vulnerability Alert (CVE-2026-119977)
Executive & SecOps Summary
SECOPS ASSESSMENTWordPress Core versions 4.7 through 7.1.3
Unauthenticated attackers can execute arbitrary code on the server by exploiting predictable staging paths during the core upgrade process
Immediately upgrade to WordPress 7.1.4 or later and restrict web access to the upgrade staging directories
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Immediate Core Update Update your WordPress installation to version 7.1.4 or higher immediately via the dashboard or WP-CLI.
# Update via WP-CLI
wp core update2. Web Application Firewall (WAF) Configuration Implement WAF rules to block direct access to PHP files within the upgrade directory. For Apache (.htaccess):
<Directory "/wp-content/upgrade">
<FilesMatch "\.php$">
Order allow,deny
Deny from all
</FilesMatch>
</Directory>3. Hardening Staging Paths Ensure that the `wp-content/upgrade` directory is not indexable and that file permissions are strictly set to prevent unauthorized writes outside of the official update process.
Block Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
This vulnerability is a Time-of-Check Time-of-Use (TOCTOU) race condition (CWE-367) within the WordPress core update mechanism. During a full-package upgrade, WordPress extracts files into a predictable, web-accessible staging directory under wp-content/upgrade/. An attacker can predict this path and inject malicious scripts during the upgrade window. When the process completes and moves the staged files to the production root, the malicious payload is deployed and executed. With a high EPSS score of 0.94 and its inclusion in the CISA KEV catalog, this vulnerability is actively being exploited in the wild to compromise WordPress sites.
Official Vendor Advisories & References
WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.