CVE DatabaseCVE-2015-20130
한국어 권고문 →
CVE-2015-201306.1/MEDIUMCWE-79

Netsweeper Web Administration Reflected XSS Vulnerability (CVE-2015-20130) Advisory

Affected Vendors
Netsweeper
Affected Components
Netsweeper
Published Date
2026-10-30

Executive & SecOps Summary

SECOPS ASSESSMENT
Affected Scope

Netsweeper versions prior to 4.0.11 and 4.1.0 through 4.1.4.

Impact

Remote attackers can execute arbitrary JavaScript in the victim's browser, potentially leading to administrative session hijacking.

Mitigation

Immediately upgrade Netsweeper to version 4.0.11, 4.1.5, or later.

Affected Products & Version Scope

Netsweeper < 4.0.11 and 4.1.0 <= version < 4.1.5

Remediation & Live Workaround Commands

PATCH & WORKAROUND

The primary remediation is to apply the official security patches provided by Netsweeper. If immediate patching is not feasible, implement the following mitigations: 1. Deploy WAF Rules: Filter incoming requests to view_server_log.php that contain suspicious payloads in the log parameter. 2. Restrict Access: Limit access to the web administration interface to internal management networks or via VPN only.

bash
apache # Example ModSecurity Rule SecRule REQUEST_URI "/webadmin/reporter/view_server_log.php" "chain,id:10001,phase:2,deny,status:403,msg:'Netsweeper XSS Attempt'" SecRule ARGS:log "@rx <script|javascript:|onerror="
Recommended Security Control & Mitigation Partner
Cloudflare Enterprise & Pro WAF
Verify your current Netsweeper version and upgrade to 4.0.11, 4.1.5, or the latest stable release immediately to mitigate this risk.

Block Exploits Instantly with Managed Virtual Patching Rules

Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.

3-min setup · Automated Zero-Day Managed Rules
Practice Exploiting & Patching This Web Vulnerability in an Interactive Lab
Launch Hands-On Security Lab

Technical Root Cause & Exploitation Mechanics

The vulnerability exists in the webadmin/reporter/view_server_log.php endpoint of the Netsweeper administration interface. It is caused by the failure to sanitize or encode the log request parameter before reflecting it into the HTML response (CWE-79). An attacker can craft a malicious URL and trick an authenticated administrator into visiting it. Once executed, the script runs within the context of the administrator's session, allowing for unauthorized actions. Recent threat intelligence from the Shadowserver Foundation indicates that this vulnerability is being actively scanned and exploited in the wild as of late 2023.

Official Vendor Advisories & References

NVD Original English Description

Netsweeper before 4.0.11 and 4.1.0 before 4.1.5 contains a reflected cross-site scripting vulnerability in webadmin/reporter/view_server_log.php that allows remote attackers to execute arbitrary JavaScript by injecting malicious code through the log request parameter, which is reflected into the HTML response without output encoding. Attackers can craft a malicious URL and induce a user to request it, resulting in arbitrary JavaScript execution within the victim's browser session against the Netsweeper web administration interface. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.

SecOps Advisory Dispatch & RSS Feed

Subscribe to Daily Vulnerability Briefings & KEV Alerts

Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.

Slack / Teams / RSS Feed:
CVE-2015-20130: Netsweeper Web Administration Reflected XSS Vulnerability (CVE-2015-20130) Advisory | CVE Pulse | CVE Pulse